Quality issues - Page 5
Close
Login to Your Account
Mercedes CLA Forum

Quality issues

This is a discussion on Quality issues within the Mercedes-Benz CLA 220 CDI forums, part of the Mercedes-Benz CLA Model Specific Forums category; I have the same rattle that you've stated Tommy (and others), it's right under the speedo on the left side of the steering (right hand ...

Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 47 of 47
Like Tree1Likes

Thread: Quality issues

  1. #41
    Friend fozyb's Avatar
    Member #
    9742
    Join Date
    Dec 2015
    Posts
    152
    Mentioned
    0 Post(s)
    I have the same rattle that you've stated Tommy (and others), it's right under the speedo on the left side of the steering (right hand drive for me). It's so annoying! Every time I hit a bump I hear it creak and rattle, and on the motorway it creaks all the time. When I keep that section pressed down there are no more creaks, just goes to show that something is loose/quality is not right. Did they tell you what it was? I have my CLA going in soon to get it checked, so I'll post here with my findings. Not very impressed at all, even my Corsa didn't have that. My car has done 3000 miles and it's a brand new October model. Other issues are:
    Collision warning sometimes comes up randomly with a loud noise (when driving down an empty road)
    Sensors sometimes go haywire whilst driving
    Creaks in the interior which I am most annoyed about!
    Last edited by fozyb; 12-20-2016 at 02:12 PM.

  • #42
    Rookie Tommy Kaira's Avatar
    Member #
    13681
    Join Date
    Nov 2016
    Posts
    32
    Mentioned
    0 Post(s)
    Quote Originally Posted by fozyb View Post
    I have the same rattle that you've stated Tommy (and others), it's right under the speedo on the left side of the steering (right hand drive for me). It's so annoying! Every time I hit a bump I hear it creak and rattle, and on the motorway it creaks all the time. When I keep that section pressed down there are no more creaks, just goes to show that something is loose/quality is not right. Did they tell you what it was? I have my CLA going in soon to get it checked, so I'll post here with my findings. Not very impressed at all, even my Corsa didn't have that. My car has done 3000 miles and it's a brand new October model. Other issues are:
    Collision warning sometimes comes up randomly with a loud noise (when driving down an empty road)
    Sensors sometimes go haywire whilst driving
    Creaks in the interior which I am most annoyed about!
    Sounds like the same rattle! I'll keep you up to date with what the dealer says.

  • #43
    Rookie Tommy Kaira's Avatar
    Member #
    13681
    Join Date
    Nov 2016
    Posts
    32
    Mentioned
    0 Post(s)
    My car is at the dealers now. They've book the loan car out to me for a week so I'll let you know what they come back to me with. I've got their CLA45 wagon so I guess they'll be keen to get mine back to me.

    Thoughts on the 45. It's got the same dash rattle. The engine/exhaust sounds terrible. It goes reasonably well and I'm getting 31.7 mpg at the moment compared to the 58-61mpg average on the same journey in my 220cdi.

  • Remove Advertisements
    MercedesCLA.org
    Advertisements
     

  • #44
    Rookie Tommy Kaira's Avatar
    Member #
    13681
    Join Date
    Nov 2016
    Posts
    32
    Mentioned
    0 Post(s)
    OK, Had the car back about 5 days so I've put about 800 miles on it since it was at the dealer.

    Quote Originally Posted by Tommy Kaira View Post
    1. Rattle under dash around steering column Seems to have been fixed (the loan car had the same rattle)
    2. Radio volume needs to be in the last fifth of the volume bar to be audible They agreed but said there were no faults so not much they could do
    3. Phone volume has to be on max with road speed under 50mph otherwise you can't hear a word As 2. above. they couldn't explain why the loan car was WAY better
    4. On cold pull away the transmission feels like a manual with a slipping clutch Full software reinstall with updates. Seems to have improved the situation noticeably. Remains to be seen if I'm satisfied
    5. In Eco mode there is enough power to get you off the line but you are then left stranded, blocking the road until the power drips through (maybe the way Eco mode is set to work?) I was told "it pulls away in 2nd in eco mode". However, since I've had it back Eco mode does pull away in 1st too. On initial collection the dynamic modes seemed to be all the same. After turning off the ignition and restarting they are working properly again BUT there is a more marked difference between them than before. This could be due to the transmission updates? Or have they updated something else too???
    6. Twice now, under steady throttle at 30-40mpg the car has shifted down to 1st for no reason Not happened since updates but it only happened twice so we will see if it comes back with more miles
    7. After being parked and pulling away, the first time you brake there is a clonk/knock from either the rear brakes or suspension After running 9 sets of tests they found the issue. However, the parts are on back order with MB (so it's obviously a common fix...but they didn't know about it??) I'm booked in at the end of the month for this fix. The advisor was vague but from what I can gather it's wheel bearing related and a special paint/grease needs to be added. Wasn't clear if there were replacing hubs or just adding paint.
    Other items of interest, kind of want a CLA45 now which is confusing me as there was a lot not to like about it. Could just be that my fast cars are all tucked away at the moment and it was nice to get a taste of a bit more speed. Could be cured by a blast in the E55? However, it was nice to see MB doing something a little different.

    I also stunned half a dozen people by fitting an entire 911 interior we'd re-trimmed into the back of my CLA saloon to deliver to the customer. It's like a tardis! (but I was pretty good at tetris in my younger days so that may have helped.)
    Last edited by Tommy Kaira; 01-11-2017 at 03:20 AM.
    Wizz likes this.

  • #45
    Rookie Tommy Kaira's Avatar
    Member #
    13681
    Join Date
    Nov 2016
    Posts
    32
    Mentioned
    0 Post(s)
    Bad news!

    The 'clutch slipping' feeling is back...BIG TIME! Yesterday, the car would barely move! It was as if it was in some sort of limp home mode. The dynamic (comfort, eco, sport) button didn't seem to do anything. Turning the car off and restarting seemed to clear the problem.
    If the dealer can't fix it this time they'll have to give me back my money or sort out a different car. It's quite dangerous actually. As before, I'll keep you all posted.

  • #46
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    4,846
    Mentioned
    47 Post(s)
    Quote Originally Posted by Tommy Kaira View Post
    Bad news!

    The 'clutch slipping' feeling is back...BIG TIME! Yesterday, the car would barely move! It was as if it was in some sort of limp home mode. The dynamic (comfort, eco, sport) button didn't seem to do anything. Turning the car off and restarting seemed to clear the problem.
    If the dealer can't fix it this time they'll have to give me back my money or sort out a different car. It's quite dangerous actually. As before, I'll keep you all posted.
    Would surely be good to get to the bottom of this ... though the temporary restart fix is bothersome cuz when I went through something similar (limp mode etc etc) the next I knew was a flatbed tow to the dealer and a massive parts replacement exercise.
    Hope yours is just a software glitch.

  • #47
    Friend fozyb's Avatar
    Member #
    9742
    Join Date
    Dec 2015
    Posts
    152
    Mentioned
    0 Post(s)
    Any updates on the dash creaking noise Tommy? Sorry to hear about your clutch woes. Hope you get it sorted!

  • Page 5 of 5 FirstFirst ... 3 4 5

    Sponsored Links

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  

    Similar Threads

    1. CLA Ride Quality
      By ajc in forum CLA General Discussion
      Replies: 47
      Last Post: 11-16-2013, 08:57 PM
    2. Quality
      By Trudy in forum CLA General Discussion
      Replies: 1
      Last Post: 09-27-2013, 06:35 PM
    3. Replies: 12
      Last Post: 08-08-2013, 03:19 PM
    4. CLA quality
      By dinosaur1 in forum CLA General Discussion
      Replies: 18
      Last Post: 03-06-2013, 02:36 PM

    Search tags for this page

    cla creaking noise

    ,
    mercedes cla issues
    ,
    mercedes quality issues
    ,
    quality problems mercedes cla
    ,
    throttle problems with mb cla
    Click on a term to search for related topics.
    About Us
    We are a community dedicated to the all new Mercedes-Benz CLA & CLA45 AMG. We offer Benz CLA Pictures, Aftermarket Accessory discussion, Questions and Answers and much more from CLA Owners across the world. Thank you for visiting the best CLA Forum on the Internet.
    Join us
    Register
    If you woud like to join our community simply click the following registration link: Register @ MercedesCLA.org