Service Required: Do Not Shift Gears, Visit Dealer
Close
Login to Your Account
Mercedes CLA Forum

Service Required: Do Not Shift Gears, Visit Dealer

This is a discussion on Service Required: Do Not Shift Gears, Visit Dealer within the CLA Problems/Issues/Complaints forums, part of the Mercedes-Benz CLA Forum category; Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Like Tree8Likes

Thread: Service Required: Do Not Shift Gears, Visit Dealer

  1. #1
    Newbie cxu60's Avatar
    Member #
    25748
    Join Date
    Apr 2019
    Posts
    2
    Mentioned
    0 Post(s)

    Service Required: Do Not Shift Gears, Visit Dealer

    Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start either, anybody have a similar experience?

  • #2
    Veteran Geo K's Avatar
    Member #
    5861
    Join Date
    Apr 2014
    Location
    Maryland
    Posts
    566
    Mentioned
    4 Post(s)
    Quote Originally Posted by cxu60 View Post
    "...Do Not Shift Gears, Visit Dealer". It won't start either...
    …...
    What model year do you have and which city are you near?

    #1: '14 250 Universe Blue (Limited Ed.) + Leath, Walnut, Parktronic, Prem Pk, Interior Pk., Multimedia , Driver Assist, Lighted Sills, LoJack, Ext. War, Wheel Locks, Random Sunglasses Holder, + (Bonus - Extra Wide Door Gaps.)
    #2: '14 250 Polar Silver + [Same as above] + Pano, (Minus Random Sunglass Holder.)

  • #3
    RSM
    RSM is offline
    Pro RSM's Avatar
    Member #
    4035
    Join Date
    Dec 2013
    Posts
    1,247
    Mentioned
    9 Post(s)
    Seems like a counterintuitive message to visit your dealer but not shift gears. How are you supposed to get there?
    Geo K, Rapidfirerob and Bahn like this.
    -Favorite Cars-
    2016 GLA 250 4Matic, Mountain Gray, Premium & Multi-Media, Blind Spot Assist, Illuminated Star, Pano Roof, Poplar wood trim, Dynamic suspension, Keyless Go, back up camera
    2014 CLA 250 4Matic, Polar Silver, Premium Package, Bi-Xenon Lights, Pano Roof, Blind Spot Assist, Burl Dash Insert. Comfort Suspension
    2014 CLA 250 FWD (traded in for Certified Pre-Owned AWD)
    2010 VW CC
    2004 VW Passat GLX-4motion
    2002 Subaru WRX
    1975 Saab 99GLE
    1971 Saab 99E

  • Remove Advertisements
    MercedesCLA.org
    Advertisements
     

  • #4
    Newbie cxu60's Avatar
    Member #
    25748
    Join Date
    Apr 2019
    Posts
    2
    Mentioned
    0 Post(s)
    Quote Originally Posted by Geo K View Post
    …...
    What model year do you have and which city are you near?

    2014 cla250, in Bay area
    Rapidfirerob likes this.

  • #5
    Veteran Geo K's Avatar
    Member #
    5861
    Join Date
    Apr 2014
    Location
    Maryland
    Posts
    566
    Mentioned
    4 Post(s)
    Quote Originally Posted by cxu60 View Post
    2014 cla250, in Bay area
    ..………...
    CXU,
    A) Looks like one of those situations, where a tow is required back to the dealer IMO - call your SA so that you can get a loaner.
    B) No, I can't recall seeing this issue on the Forum - if there are no other clues like leaking fluid, then it is a possible software glitch.
    C) Best of luck and please come back here and update us.

    Rapidfirerob and RSM like this.
    #1: '14 250 Universe Blue (Limited Ed.) + Leath, Walnut, Parktronic, Prem Pk, Interior Pk., Multimedia , Driver Assist, Lighted Sills, LoJack, Ext. War, Wheel Locks, Random Sunglasses Holder, + (Bonus - Extra Wide Door Gaps.)
    #2: '14 250 Polar Silver + [Same as above] + Pano, (Minus Random Sunglass Holder.)

  • #6
    Pro Rapidfirerob's Avatar
    Member #
    6298
    Join Date
    May 2014
    Location
    near Berkeley, California
    Posts
    2,842
    Mentioned
    21 Post(s)
    I bought my 14 250 in Marin. I've primarily taken it to Fairfield Mercedes, as I used to work there, and now work in Vallejo. I've taken it for service to Marin once, when
    Fairfield wouldn't investigate when I had a CEL that disappeared after a few days. Marin did and fixed the problem. Where are you located? I'm in Richmond, near El Cerrito.
    2014 CLA 250: Night Black, Beige Interior, Pano Roof, Spoiler, Bi Xenons, Sport Package, Burl Walnut Wood Trim, Opticoat, Xpel, Alembic Spoiler bass, Eve IONA bass, Michael Kelly acoustic bass guitar, Gibson J40, Carvin Cobalt 750, Genz Benz Shuttle 6.2 and 6.0 amps, Two Gallien-Krueger Neo II 1X12 cabs, BOSS TU-3 tuner, Guardian of The Mighty Door Gap.

  • #7
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    8,950
    Mentioned
    109 Post(s)
    If its a persistent gearbox error tow it
    Rapidfirerob likes this.

  • #8
    Newbie jillbenz's Avatar
    Member #
    9447
    Join Date
    Sep 2015
    Posts
    5
    Mentioned
    0 Post(s)
    This happened to me a few months ago and it was just the battery. They jumped my car to get it to the dealer (had to double jump it, whatever that means) and the dealer replaced the battery. Haven’t had the problem since. Hopefully that’s all your CLA needs too!

  • #9
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    8,950
    Mentioned
    109 Post(s)
    Quote Originally Posted by jillbenz View Post
    This happened to me a few months ago and it was just the battery. They jumped my car to get it to the dealer (had to double jump it, whatever that means) and the dealer replaced the battery. Haven’t had the problem since. Hopefully that’s all your CLA needs too!
    that's good to know ...
    no such notice when my batteries dropped dead after shutdown -> just the popping trunk syndrome ... 8-)

  • #10
    Newbie Maine4matic's Avatar
    Member #
    14937
    Join Date
    Feb 2017
    Location
    Portland, Maine
    Posts
    20
    Mentioned
    0 Post(s)

    United States

    s
    Quote Originally Posted by cxu60 View Post
    Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start either, anybody have a similar experience?
    My '14 CLA250 4matic threw the same code when I was about 0.25 miles into my commute, but it was -14F out, simple turned the car off & on. Error cleared, has not shown-up again!
    Geo K likes this.

  • Page 1 of 2 1 2 LastLast

    Sponsored Links

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  

    Similar Threads

    1. CLA 2016 Service Required Do Not Shift Gears
      By marlie& in forum CLA Problems/Issues/Complaints
      Replies: 3
      Last Post: 02-14-2017, 07:16 AM
    2. Engine light on, cant shift gears.
      By Bebst in forum CLA Problems/Issues/Complaints
      Replies: 4
      Last Post: 08-08-2015, 06:14 AM
    3. Service Required: Do not shift gears
      By gwalker35 in forum CLA Problems/Issues/Complaints
      Replies: 10
      Last Post: 06-20-2015, 07:54 AM
    4. Error Message -- "Do Not Shift Gears"
      By CLA_Renee in forum CLA Problems/Issues/Complaints
      Replies: 0
      Last Post: 12-02-2014, 09:04 PM
    5. Tire Issue - Found and Solved, No dealer intervention desired nor required.
      By Jupiter Red in forum CLA Problems/Issues/Complaints
      Replies: 6
      Last Post: 06-03-2014, 11:58 PM

    Search tags for this page

    service required do not shift gears mercedes

    Click on a term to search for related topics.
    About Us
    We are a community dedicated to the all new Mercedes-Benz CLA & CLA45 AMG. We offer Benz CLA Pictures, Aftermarket Accessory discussion, Questions and Answers and much more from CLA Owners across the world. Thank you for visiting the best CLA Forum on the Internet.
    Join us
    Register
    If you woud like to join our community simply click the following registration link: Register @ MercedesCLA.org