Software update to fix Cylinder #1 and #2 Misfires?
Close
Login to Your Account
Mercedes CLA Forum

Software update to fix Cylinder #1 and #2 Misfires?

This is a discussion on Software update to fix Cylinder #1 and #2 Misfires? within the CLA Problems/Issues/Complaints forums, part of the Mercedes-Benz CLA Forum category; I was driving from PGH -> Philly (Ive done this trip at least 15 times in the past 2 years). Its roughly 300miles I thought ...

Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By MrVettel

Thread: Software update to fix Cylinder #1 and #2 Misfires?

  1. #1
    Regular SunsetCLA's Avatar
    Member #
    9000
    Join Date
    May 2015
    Posts
    446
    Mentioned
    6 Post(s)

    Software update to fix Cylinder #1 and #2 Misfires?

    I was driving from PGH -> Philly (Ive done this trip at least 15 times in the past 2 years). Its roughly 300miles
    I thought it was a transmission issue at the time, so when I found out from the dealer it was a misfire - I was surprised.

    Regardless, here is the origin story for my issue for those interested.
    30miles out of Philly, my car shifted (auto- S mode) from gear 5 to 6. Immediately it started to rumble/jitter/shake + engine light turned on. I began to start loosing power. So I pulled over and the turned off the car. Restarted - issue fixed and engine light disappeared.

    10 miles out of Philly, the issue came back. This time again from gear 5 to 6. So shifted in manual mode and slowed down till I was in 5th gear. Was fine for a while until issue (shaking/jittering/rumbling/power loss) started in 5th. Slowed to gear 4, and the issue resolved. The issue started happening at 4th gear. Thankfully I got to my apartment and parked. Car got towed to the closest MB dealer.

    So it seems they did a software fix/update - has anyone experienced this before? My only concern is that the issue may happen again as it was some kind of "software problem"

    This is what the dealer wrote:
    Pg1
    Name:  scan1gki1.jpeg
Views: 129
Size:  98.6 KB
    Pg 2
    Name:  scan2vbk2s.jpeg
Views: 128
Size:  63.3 KB
    Last edited by SunsetCLA; 05-10-2019 at 01:23 PM.
    2015 CLA250C4 Sport+
    Aug 2015 Delivery

  • #2
    Friend Caug's Avatar
    Member #
    17202
    Join Date
    May 2017
    Posts
    172
    Mentioned
    1 Post(s)
    45 or 250?
    2015 GLA45 AMR PERFORMANCE STG2+AMS INTAKE+TRS+BRONDEX DP 200CEL+HG MOTORSPORTS 2 PIECE ROTORS+OZ ULTRALEGGERA HTL 19X8 25MM & 20MM SPACERS+AMS TITANIUM STRUT BRACE

  • #3
    Regular SunsetCLA's Avatar
    Member #
    9000
    Join Date
    May 2015
    Posts
    446
    Mentioned
    6 Post(s)
    Quote Originally Posted by Caug View Post
    45 or 250?
    250

    .
    2015 CLA250C4 Sport+
    Aug 2015 Delivery

  • Remove Advertisements
    MercedesCLA.org
    Advertisements
     

  • #4
    Newbie MrVettel's Avatar
    Member #
    25710
    Join Date
    Apr 2019
    Location
    Surrey, BC
    Posts
    3
    Mentioned
    0 Post(s)

    Mercedes Logo Flat Cylinder Misfire

    I had the exact same issue with my 2014 CLA 250. Started at 69000 km, had cylinders 3 & 4 misfire. Loss of power and strong vibration and CE light on. Then after shut down and restart, it would run fine and CE light would clear. First fix from dealership was to replace fuel rail sensor (covered under star cert. warranty). Car ran well for a couple weeks, then the misfire re-occurred. I took it back to the dealership, they ran compression test and found low compression and "scorching" in cylinders 3 and 4. They ended up having to send the engine block and cylinder heads to Toronto for repairs (apparently the only Mercedes certified machine shop in Canada). Total repair time took approx. 7 weeks. Fortunately repair and rental costs were covered under warranty. I have had the car back for over a month now and have not had any more misfires. I read in other forums that the M270 and M274 engines had some faulty components at the manufacturing stage. In my case this was certainly not a software related issue. Service Advisor told me that piston rings were faulty and ended up damaging cylinder walls that had to be re-bored.

    Good luck!
    Rapidfirerob likes this.

  • #5
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    9,181
    Mentioned
    110 Post(s)

    Software update to fix Cylinder #1 and #2 Misfires?

    Faulty rings? Thats bad ... could be fab flash or dinged edges which would explain the scored walls
    European delivery 20140331

  • #6
    Regular SunsetCLA's Avatar
    Member #
    9000
    Join Date
    May 2015
    Posts
    446
    Mentioned
    6 Post(s)
    Quote Originally Posted by MrVettel View Post
    I had the exact same issue with my 2014 CLA 250. Started at 69000 km, had cylinders 3 & 4 misfire. Loss of power and strong vibration and CE light on. Then after shut down and restart, it would run fine and CE light would clear. First fix from dealership was to replace fuel rail sensor (covered under star cert. warranty). Car ran well for a couple weeks, then the misfire re-occurred. I took it back to the dealership, they ran compression test and found low compression and "scorching" in cylinders 3 and 4. They ended up having to send the engine block and cylinder heads to Toronto for repairs (apparently the only Mercedes certified machine shop in Canada). Total repair time took approx. 7 weeks. Fortunately repair and rental costs were covered under warranty. I have had the car back for over a month now and have not had any more misfires. I read in other forums that the M270 and M274 engines had some faulty components at the manufacturing stage. In my case this was certainly not a software related issue. Service Advisor told me that piston rings were faulty and ended up damaging cylinder walls that had to be re-bored.

    Good luck!
    Oh boy lol...this doesn't sound good. My issue so far is fine with whatever software fix they did. But I feel like my car jerks a bit more now from gears 1-3. Hopefully thats not a factor into the misfire issue.

    Thanks for your information. Really insightful
    2015 CLA250C4 Sport+
    Aug 2015 Delivery

  • #7
    Regular SunsetCLA's Avatar
    Member #
    9000
    Join Date
    May 2015
    Posts
    446
    Mentioned
    6 Post(s)
    Damn, looks like it happened again from Philly -> PGH...ugh. My warranty is almost over and this ofc happens right at the end after miles of reliable driving
    2015 CLA250C4 Sport+
    Aug 2015 Delivery

  • #8
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    9,181
    Mentioned
    110 Post(s)
    Quote Originally Posted by MrVettel View Post
    I had the exact same issue with my 2014 CLA 250. Started at 69000 km ... Fortunately repair and rental costs were covered under warranty. I have had the car back for over a month now and have not had any more misfire ...
    So you got your 2014 car back mar/apr 2019 ... extended warranty??
    European delivery 20140331

  • #9
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    9,181
    Mentioned
    110 Post(s)
    Quote Originally Posted by SunsetCLA View Post
    Damn, looks like it happened again from Philly -> PGH...ugh. My warranty is almost over and this ofc happens right at the end after miles of reliable driving
    Oh man another software fix??
    European delivery 20140331

  • Sponsored Links

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  

    Similar Threads

    1. Eco stop start problems/misfires?
      By rxccode in forum CLA Problems/Issues/Complaints
      Replies: 39
      Last Post: 02-08-2016, 06:00 PM
    2. Oil Leaking From Cam Plug and Software Update Broke My Car
      By ayoo in forum CLA Problems/Issues/Complaints
      Replies: 12
      Last Post: 02-25-2015, 06:30 PM
    3. Software Update if you are in the Bay Area
      By TValdez in forum West / West Coast Owners
      Replies: 0
      Last Post: 11-27-2013, 11:29 AM
    4. Service Campaign 2013110004 - Software Update
      By new buyer in forum CLA General Discussion
      Replies: 2
      Last Post: 11-27-2013, 11:17 AM
    5. Got this from an MB World Post - RE: Software update.
      By Jupiter Red in forum CLA General Discussion
      Replies: 11
      Last Post: 11-25-2013, 10:04 PM
    About Us
    We are a community dedicated to the all new Mercedes-Benz CLA & CLA45 AMG. We offer Benz CLA Pictures, Aftermarket Accessory discussion, Questions and Answers and much more from CLA Owners across the world. Thank you for visiting the best CLA Forum on the Internet.
    Join us
    Register
    If you woud like to join our community simply click the following registration link: Register @ MercedesCLA.org