Could muffler delete cause misfires?
Close
Login to Your Account
Mercedes CLA Forum

Could muffler delete cause misfires?

This is a discussion on Could muffler delete cause misfires? within the CLA Problems/Issues/Complaints forums, part of the Mercedes-Benz CLA Forum category; I have a 2019 250 with just a muffler delete and around 10K miles on it. 2 weeks ago I had an issue where it ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Like Tree1Likes

Thread: Could muffler delete cause misfires?

  1. #1
    Newbie SuperFrankieOSX's Avatar
    Member #
    25666
    Join Date
    Apr 2019
    Location
    Long Island, NY
    Posts
    7
    Mentioned
    0 Post(s)

    Could muffler delete cause misfires?

    I have a 2019 250 with just a muffler delete and around 10K miles on it. 2 weeks ago I had an issue where it was misfiring in cylinders 1 and 4 and I had it towed to the dealer. Dealer said it was the fuel injectors so they replaced them and the coils at the same time. Car drove fine for a few days until the check engine light came on again. This time it ran okay and I had it scanned at autozone which gave me the code "P0299, Turbo Underboost" this time it was a hose on the turbo wastegate that popped off, they fixed it again and I drove it for 2 weeks without any issues. Then the other day I came to a stop and was feeling a lot of vibrations/ engine wasn't running well. Took it to dealer and now I have it back and they told me that the issue went away after starting it back up, they reset the driving adaptors and gave it back to me. They keep questioning me about the exhaust to which I denied. Anyways should i put the muffler back on? I am just so stressed about it and I don't want it to cause any issues with my car. Thank you
    -Frankie

  • #2
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    9,206
    Mentioned
    110 Post(s)

    Could muffler delete cause misfires?

    Lots of folks did muffler deletes etc so unlikely thats related to the various engine issues you noted
    All the little problems you described makes one wonder who messed with the motor ...

    And whats a “driving adapter” ???
    European delivery 20140331

  • #3
    Veteran Geo K's Avatar
    Member #
    5861
    Join Date
    Apr 2014
    Location
    Maryland
    Posts
    578
    Mentioned
    5 Post(s)
    JMC,
    Would you care to tell us about Euro Delivery 20140331?
    #1: '14 250 Universe Blue (Limited Ed.) + Leath, Walnut, Parktronic, Prem Pk, Interior Pk., Multimedia , Driver Assist, Lighted Sills, LoJack, Ext. War, Wheel Locks, Random Sunglasses Holder, + (Bonus - Extra Wide Door Gaps.)
    #2: '14 250 Polar Silver + [Same as above] + Pano, (Minus Random Sunglass Holder.)

  • Remove Advertisements
    MercedesCLA.org
    Advertisements
     

  • #4
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    9,206
    Mentioned
    110 Post(s)
    Quote Originally Posted by Geo K View Post
    JMC,
    Would you care to tell us about Euro Delivery 20140331?
    Theres a few representative pix and details in my album ...
    That was my first visit to DE, first Benz, and first euro delivery. Really cool trip.
    Geo K likes this.
    European delivery 20140331

  • #5
    Newbie SuperFrankieOSX's Avatar
    Member #
    25666
    Join Date
    Apr 2019
    Location
    Long Island, NY
    Posts
    7
    Mentioned
    0 Post(s)
    Quote Originally Posted by jmc View Post
    Lots of folks did muffler deletes etc so unlikely thats related to the various engine issues you noted
    All the little problems you described makes one wonder who messed with the motor ...

    And whats a “driving adapter” ???
    I believe it's what allows the transmission to "adapt" to your driving style. I haven't touched anything with the computer and this issue has been on and off as of late. Taking it back again today.

  • #6
    Regular SunsetCLA's Avatar
    Member #
    9000
    Join Date
    May 2015
    Posts
    450
    Mentioned
    6 Post(s)
    I have had the same exact issue and I have no modifications on my car. I made a thread about it earlier. It got fixed with their software update but yesterday I had the same issue happen midway through a 300 mile trip...I reset it and the car didn't give me any new issues. I have it scheduled to take the car in and get it fixed up. Really worrying

    https://www.mercedescla.org/forum/64...-misfires.html
    2015 CLA250C4 Sport+
    Aug 2015 Delivery

  • #7
    Newbie SuperFrankieOSX's Avatar
    Member #
    25666
    Join Date
    Apr 2019
    Location
    Long Island, NY
    Posts
    7
    Mentioned
    0 Post(s)
    Quote Originally Posted by SunsetCLA View Post
    I have had the same exact issue and I have no modifications on my car. I made a thread about it earlier. It got fixed with their software update but yesterday I had the same issue happen midway through a 300 mile trip...I reset it and the car didn't give me any new issues. I have it scheduled to take the car in and get it fixed up. Really worrying

    https://www.mercedescla.org/forum/64...-misfires.html
    I know it gets really annoying and stressful, I am having the muffler put back on so they don't have any more stupid excuses for me.

  • #8
    Newbie SuperFrankieOSX's Avatar
    Member #
    25666
    Join Date
    Apr 2019
    Location
    Long Island, NY
    Posts
    7
    Mentioned
    0 Post(s)
    Quote Originally Posted by jmc View Post
    Lots of folks did muffler deletes etc so unlikely thats related to the various engine issues you noted
    All the little problems you described makes one wonder who messed with the motor ...

    And whats a “driving adapter” ???
    anyways I'm getting the muffler put back on so they can't give me an excuse any more. I am so frustrated and annoyed with this.

  • #9
    jmc
    jmc is offline
    Ninja jmc's Avatar
    Member #
    7493
    Join Date
    Sep 2014
    Posts
    9,206
    Mentioned
    110 Post(s)
    Quote Originally Posted by SuperFrankieOSX View Post
    I believe it's what allows the transmission to "adapt" to your driving style. I haven't touched anything with the computer and this issue has been on and off as of late. Taking it back again today.
    Would you mind asking HOW they reset the transmission adaptation??
    European delivery 20140331

  • #10
    Newbie SuperFrankieOSX's Avatar
    Member #
    25666
    Join Date
    Apr 2019
    Location
    Long Island, NY
    Posts
    7
    Mentioned
    0 Post(s)
    Quote Originally Posted by jmc View Post
    Quote Originally Posted by SuperFrankieOSX View Post
    I believe it's what allows the transmission to "adapt" to your driving style. I haven't touched anything with the computer and this issue has been on and off as of late. Taking it back again today.
    Would you mind asking HOW they reset the transmission adaptation??
    I'll ask them when I go to pick the car up once it's done, now that the muffler is back on it feels a bit better to drive, even though the check engine light is still on.

  • Page 1 of 2 1 2 LastLast

    Sponsored Links

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    About Us
    We are a community dedicated to the all new Mercedes-Benz CLA & CLA45 AMG. We offer Benz CLA Pictures, Aftermarket Accessory discussion, Questions and Answers and much more from CLA Owners across the world. Thank you for visiting the best CLA Forum on the Internet.
    Join us
    Register
    If you woud like to join our community simply click the following registration link: Register @ MercedesCLA.org