Mercedes CLA Forum banner

21 - 35 of 35 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #22

·
Registered
Joined
·
3 Posts
Oh wow! This sounds a lot like me right now. Do you have anything done to the car? I have a 2014 CLA 250 4matic as well! I have a muffler delete, AEM intake, turbo kits BOV, stage I tune and I have it lowered on H&R springs. At around 50k miles I had a coolant leak but found out at shop that the water pump and my thermostat were out too. That caused me a huge over heating issue. Please watch who you take your car to because this guy ended up breaking all the bolts on the head of the engine causing it to make knocking noises, it wouldn’t drive the same and my tune didn’t run the same. I had it sitting for a long time until I came up with the money to fix the head of the engine that this guy broke. I took it to benz and they told my car was running on 2 cylinders, the head of the engine was done, but guess what? My alternator and battery went out as well and that was around 60k miles. Repairs were $9k! My pockets are still recovering from that. Then after that I was driving around the city and out of no where my 4matic system is off, no abs, no traction control, no power steering and no emergency brake. I took it to a Benz specialist this time because damn I don’t have that kind of money rn and he told me a speed sensor that caused all this. Which is what I think may be happening to you. Now it’s driving perfect, sometimes the shifting seems off and I get that pre functions display on my screen. I’ve been hearing a new sound though and it’s the clunking and I do believe it’s the differential. Also my motors mounts have been suffering bad! As of right now I only see two cracked :(
 

·
Registered
Joined
·
128 Posts
Discussion Starter #26
Mine is completely stock, as it is actually my wife's car!

What speed sensor was bad, and do you know the location/part number of this sensor?
 

·
Registered
Joined
·
3 Posts
It was the back left speed sensor and I have a friend that checked it. He was only able to give me the code so I went to a Benz specialist and asked! Replacing the speed sensor came out to $160
 

·
Registered
Joined
·
128 Posts
Discussion Starter #28
It was the back left speed sensor and I have a friend that checked it. He was only able to give me the code so I went to a Benz specialist and asked! Replacing the speed sensor came out to $160
Are you talking about the ABS wheel sensors?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
128 Posts
Discussion Starter #29
Changed the aux battery today and the right front ABS wheel speed sensor.

Supposedly the stealership had changed both front and rear sensors about 10k miles ago. However, I pulled all of them today, the rear ones were clean and looked new. The fronts were caked with crud all around the sensor. No way they were changed at any time since this car was new!

Anyway, after this the car works fine. I didn’t drive it a lot, but seems to have no issues are messages in message center.

If I can find what my wife wants, I will be trading this in ASAP! Shame too we love this little Edition 1, but Me thinks it’s just got to go!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11,851 Posts
At least we now know how those sensors can cause havoc
 

·
Registered
Joined
·
128 Posts
Discussion Starter #33
So, the stealership told me last year when they were supposed to have changed my front ABS speed sensors that the had to be changed in pairs because if you didn’t as soon as you changed one, The other one would fail. Well at least they didn’t lie about that! The left one has now failed. Ordered one last night from FCP Euro.
As soon as I install this and get all messages and codes cleared, this thing is going away! My wife wanted to give it a chance, but I’m just tired of the constant breakdowns. This thing is worse than a 1970’s Harley Davidson!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
128 Posts
Discussion Starter #35
Dropped off the CLA 250 to the dealership!

Adios little MB - I hate to see you go, but I am so happy to see you leave!!


Sent from my iPhone using Tapatalk
 
21 - 35 of 35 Posts
Top