Mercedes CLA Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Any others have this problem? Service can't find anything wrong with the vehicle. Suddenly just unable to accelerate. Very scary!
 

·
Registered
Joined
·
1,112 Posts
Any others have this problem? Service can't find anything wrong with the vehicle. Suddenly just unable to accelerate. Very scary!
You mean limp mode?
 

·
Registered
Joined
·
1,128 Posts
Any others have this problem? Service can't find anything wrong with the vehicle. Suddenly just unable to accelerate. Very scary!
Dealers won't do anything if they can't duplicate the problem. I suggest you find a way to record it and show them a video evidence. Make sure the gear shifter and gear display are visible.
 

·
Registered
Joined
·
1 Posts
We've had our CLA for about 2 months now and it's been in the shop for stopping in traffic 3 times. About a week 2 times. The first time we just wrote it off as random thing. However from all the reading it seems that this is not just a random problem. They are still working on it as I type now. We shall see what happens. This is the kind of thing you read about about but it doesn't happen to you. We would like to get money back and upgrade to C class. Somehow I don't think it's going to be a easy process. The first weeks we weren't even in town to drive it. So basically we've had the car for a month.. Very dangerous situation but who has extra cash to lose thousands of dollars without going through the process with big companies when your car is one of the few that don't act right. Keep you posted on what happens.
 

·
Registered
Joined
·
11,606 Posts
We've had our CLA for about 2 months now and it's been in the shop for stopping in traffic 3 times. About a week 2 times. The first time we just wrote it off as random thing. However from all the reading it seems that this is not just a random problem. They are still working on it as I type now. We shall see what happens. This is the kind of thing you read about about but it doesn't happen to you. We would like to get money back and upgrade to C class. Somehow I don't think it's going to be a easy process. The first weeks we weren't even in town to drive it. So basically we've had the car for a month.. Very dangerous situation but who has extra cash to lose thousands of dollars without going through the process with big companies when your car is one of the few that don't act right. Keep you posted on what happens.
Do you recall any error messages on the info screen?
 

·
Registered
Joined
·
459 Posts
try the new motor, transmission software...

because the DCT is build like this


1. clutch gears 1, 3, 5, 7
2. clutch gears 2, 4, 6
 

·
Registered
Joined
·
15 Posts
I had this happen on several occasions as well! Always when driving on the highway for an extended period of time (1 hr+), and instead of downshift when decelerating, it would slip into neutral. Very startling indeed when you go to accelerate again..!

I mentioned the issue to my dealership and they took it very seriously. They ran extensive testing over a 6 week period and ended up replacing the clutch. It's been perfectly fine ever since. Don't hesitate to ask your dealership to reach out to Mercedes Silverstar in Montreal, Canada. At the very least they'll have a record of someone else experiencing the same problem!
 

·
Registered
Joined
·
11,606 Posts
I had this happen on several occasions as well! Always when driving on the highway for an extended period of time (1 hr+), and instead of downshift when decelerating, it would slip into neutral. Very startling indeed when you go to accelerate again..!

I mentioned the issue to my dealership and they took it very seriously. They ran extensive testing over a 6 week period and ended up replacing the clutch. It's been perfectly fine ever since. Don't hesitate to ask your dealership to reach out to Mercedes Silverstar in Montreal, Canada. At the very least they'll have a record of someone else experiencing the same problem!
Just the clutch??
 

·
Registered
Joined
·
1 Posts
Thank you for posting your case. It is good to know there are other cases for this issue.The same thing happened to me 3 times. Once on highway and by the time I realized what was happening I was down to 50km/hour from 100!. My dealer just hooks the computer up to the code reader and tells me they cannot see any errors. Sure enough they cannot replicate it with a 10 min test drive either. It amazes me how they take such a safety issue lightly. I am sure there has been more reports. I am going to send them a letter and ask for disclosure to see how many reports they have had world wide. It is so random and unpredictable that could cause an accident every time it happens!
 

·
Registered
Joined
·
272 Posts
Please record a complaint on the NHTSA website for others to know they are not alone. It may put some pressure on MB too. My 14 had a similar problems and went into limp mode a few times without throwing a code. One time I resorted to turning the car off while I was moving and turning it back on and when the engine came back on the car was in neutral. Not sure if that helps at all. Made lots of noise at dealer and traded-up to a 15 that has been basically trouble-free.
 

·
Registered
Joined
·
11,606 Posts
Thank you for posting your case. It is good to know there are other cases for this issue.The same thing happened to me 3 times. Once on highway and by the time I realized what was happening I was down to 50km/hour from 100!. My dealer just hooks the computer up to the code reader and tells me they cannot see any errors. Sure enough they cannot replicate it with a 10 min test drive either. It amazes me how they take such a safety issue lightly. I am sure there has been more reports. I am going to send them a letter and ask for disclosure to see how many reports they have had world wide. It is so random and unpredictable that could cause an accident every time it happens!
Fourth time would be a lemon case?
And by "code reader" is it really just that an obd toy or did they put their SDS on it and go through an "initial quick test" which logs literally everything ... from how many times the radar beeped to how many times one called mbrace and when.
 

·
Registered
Joined
·
1,112 Posts
Thank you for posting your case. It is good to know there are other cases for this issue.The same thing happened to me 3 times. Once on highway and by the time I realized what was happening I was down to 50km/hour from 100!. My dealer just hooks the computer up to the code reader and tells me they cannot see any errors. Sure enough they cannot replicate it with a 10 min test drive either. It amazes me how they take such a safety issue lightly. I am sure there has been more reports. I am going to send them a letter and ask for disclosure to see how many reports they have had world wide. It is so random and unpredictable that could cause an accident every time it happens!
I know this is difficult, but get a dash cam and see if you can record it every time you get in the car. Then show them the proof, and if they cannot fix it, warranty owes you a new car :)
 

·
Registered
Joined
·
11,606 Posts
Might be the trans control unit
Was in my case
 
1 - 18 of 18 Posts
Top