Mercedes CLA Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello CLA community,

I am having a nightmare of an issue and am curious if anybody can help me out.
I recently had my coolant thermostat fixed a week and half prior to these crankshaft position sensor issues arising. The vehicle was running great as can be then boom... the vehicle jerked me while cruising and locked me into comfort mode with no CEL and had no throttle response, was stuck in 7th gear, and the vehicle would not downshift until 1000-500 rpms basically reaching a full stop. In addition, the vehicle would not allow me to use paddle shifters to downshift as well. This repeated over and over again on my way home from work and eventually jerked me and threw a CEL.

Turns out, the CEL was for a the crankshaft position sensor codes above. Turns out I know a 20yrs experience Mercedes technician with his own garage/lift and he was able to replace the sensor. Car drove great that night and the next morning back to the same issue with a CEL. The Mercedes tech found the same code and did multiple test drives to try and recalibrate the computer but was not able to fix the issue.

I am worried something was damaged when the thermostat was installed as the manifold has to be removed for that job which is near the crankshaft and all wiring.

Has anybody ran into a similar issue? I am at a true loss and have not been able to drive my car for weeks.

Feel free to ask me any questions to help further diagnose.


Thank you.
 

· Registered
Joined
·
5 Posts
Was it a mercedes crank sensor or aftermarket, always the potential it is a bad part, in the past I had an issue with an aftermarket crank sensor on a CLK500 not working, used OEM and problem solved
 

· Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Hello having the same problem to yourself had the thermostat replaced and now a jerking and a mil for crank sensor did you get the the bottom of this ?
Hello Mercman,
Unfortunately I was not able to get to the bottom of this. I ended up selling the vehicle as is. I replaced the sensor and did multiple other tests. I can’t believe you had replaced the sensor and got the same issue as a result. Fix one thing on high mileage cars and it opens up a can of worms sometimes. Wish the best for you man.
 

· Registered
Joined
·
4 Posts
Hello having the same problem to yourself had the thermostat replaced and now a jerking and a mil for crank sensor did you get the the bottom of this ?
Hey did you ever find out?
I’m having the same problem, crankshaft position sensor A on a 2016 250. I purchased the part directly from the dealer and can’t even locate it on the car. Any help would be greatly appreciated!!
 
1 - 8 of 8 Posts
Top