Mercedes CLA Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a 2019 250 with just a muffler delete and around 10K miles on it. 2 weeks ago I had an issue where it was misfiring in cylinders 1 and 4 and I had it towed to the dealer. Dealer said it was the fuel injectors so they replaced them and the coils at the same time. Car drove fine for a few days until the check engine light came on again. This time it ran okay and I had it scanned at autozone which gave me the code "P0299, Turbo Underboost" this time it was a hose on the turbo wastegate that popped off, they fixed it again and I drove it for 2 weeks without any issues. Then the other day I came to a stop and was feeling a lot of vibrations/ engine wasn't running well. Took it to dealer and now I have it back and they told me that the issue went away after starting it back up, they reset the driving adaptors and gave it back to me. They keep questioning me about the exhaust to which I denied. Anyways should i put the muffler back on? I am just so stressed about it and I don't want it to cause any issues with my car. Thank you
-Frankie
 

·
Registered
Joined
·
9,702 Posts
Lots of folks did muffler deletes etc so unlikely thats related to the various engine issues you noted
All the little problems you described makes one wonder who messed with the motor ...

And whats a “driving adapter” ???
 

·
Registered
Joined
·
602 Posts
JMC,
Would you care to tell us about Euro Delivery 20140331?
:mblogoblack:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Lots of folks did muffler deletes etc so unlikely thats related to the various engine issues you noted
All the little problems you described makes one wonder who messed with the motor ...

And whats a “driving adapter” ???
I believe it's what allows the transmission to "adapt" to your driving style. I haven't touched anything with the computer and this issue has been on and off as of late. Taking it back again today.
 

·
Registered
Joined
·
503 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #7
I have had the same exact issue and I have no modifications on my car. I made a thread about it earlier. It got fixed with their software update but yesterday I had the same issue happen midway through a 300 mile trip...I reset it and the car didn't give me any new issues. I have it scheduled to take the car in and get it fixed up. Really worrying

https://www.mercedescla.org/forum/64-cla-problems-issues-complaints/38832-software-update-fix-cylinder-1-2-misfires.html
I know it gets really annoying and stressful, I am having the muffler put back on so they don't have any more stupid excuses for me.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Lots of folks did muffler deletes etc so unlikely thats related to the various engine issues you noted
All the little problems you described makes one wonder who messed with the motor ...

And whats a “driving adapter” ???
anyways I'm getting the muffler put back on so they can't give me an excuse any more. I am so frustrated and annoyed with this.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
I believe it's what allows the transmission to "adapt" to your driving style. I haven't touched anything with the computer and this issue has been on and off as of late. Taking it back again today.
Would you mind asking HOW they reset the transmission adaptation??
I'll ask them when I go to pick the car up once it's done, now that the muffler is back on it feels a bit better to drive, even though the check engine light is still on.
 

·
Registered
Joined
·
9,702 Posts
I'll ask them when I go to pick the car up once it's done, now that the muffler is back on it feels a bit better to drive, even though the check engine light is still on.
Yes thank you ... would be beneficial to get it straight from the horses mouth
The exhaust system is “tuned” to naturally extract the exhaust gases and sometimes depending on the particular engine a change here and there messes with that
That CEL may be a persistent code by now so the service team will have to log it and clear it ... hope they saved the initial test and final test data files so you can see what they fixed
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
I'll ask them when I go to pick the car up once it's done, now that the muffler is back on it feels a bit better to drive, even though the check engine light is still on.
Yes thank you ... would be beneficial to get it straight from the horses mouth
The exhaust system is “tuned” to naturally extract the exhaust gases and sometimes depending on the particular engine a change here and there messes with that
That CEL may be a persistent code by now so the service team will have to log it and clear it ... hope they saved the initial test and final test data files so you can see what they fixed
yeah let's hope this fixes it, its gotta be something with a computer module because the problem isn't persistent and is very on and off it seems.
 
1 - 12 of 12 Posts
Top