Mercedes CLA Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,725 Posts
Discussion Starter · #1 · (Edited)
Anyone have a fuel pump module schematic. Im trying to find out which wire gives the pump in the tank power
Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter · #3 ·
If worse comes to worse I will drop the tank to track the wires. I want to try to see if that module is functioning properly or not.
 

·
Registered
Joined
·
3 Posts
If worse comes to worse I will drop the tank to track the wires. I want to try to see if that module is functioning properly or not.
Did you ever get this solved? I know its an old thread, but I'm in the process of the same thing with my car. Trying to do a flow test with my fuel pump.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter · #5 ·
I ended up having to drop the tank and replace the fuel pump.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter · #7 ·
The car would not start. I replaced the high pressure pump first and still wasn't getting any fuel to the rail so tested the pump and it was not pushing enough voltage.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter · #9 · (Edited)
iirc it was sending a low pressure code. That's why i thought maybe it was the high pressure pump but it didn't resolve the issue. Once the tank was dropped we just tested voltage right at the plug on top of the tank. Side not exhaust was only moved to the side and not completely removed to drop tank. I still have an extra high pressure pump sitting in the garage. Not sure if it functions properly anymore.
 
1 - 9 of 9 Posts
Top