Mercedes CLA Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi there guys,

So, first of all I salute you all and I hope to have someone around that had the same problem...

Well, the car is a CLA250, 2.0 - m270 engine - 2013 (Europe). I bought it couple months ago, happy-ish about it but still wanted a change. I had to let go my good old coupe. Coming from a C180 - 2004, never had such "problems" its entire life :))
For now I had to replace a thermostat (not faulty but thought so...), a water pump, some hoses here there, I'll have to replace the crankshaft seal because it makes chirp sounds like its a bird, not a car at all... and soon will do an aftermarket air intake because the OEM one has a hole around the turbo... guess it's hotter (pun intended) and the MB guys never thought it'll melt that plastic off... so why not going for something else instead of the stock one. Meh, wannabe "upgrades".

Now, getting to the initial point of discussion, I just had a short trip downtown and when I got back I stopped by and went to fuel up (I just dont like the idea of going on reserve, that's me since the very first car owned. OCD? Maybe...) but guess what... the tank just 'discharged' a good amount of fuel out. I noticed that the gas pumps were 'closing' around every 10-15 seconds like the tank was full... but I thought like... yeah, well, since it's never that empty, maybe gases build up in there and somehow it happens... but tonight it was more than that and she puked on me like never before... twice. I had to go wash it cause it was petrol all over me, the fender, the wheel... anyway.

So, with that being said... did anyone had to go through this? Is there any specific things that I should look up for?

Hope will hear from couple of you back so I can work this out too. Btw, if there's anything that I forgot mentioning, please feel free to rage at me...

Cheers,
Daniel
 

·
Registered
Joined
·
762 Posts
Hi Daniel,
NBert had this same problem and started a thread titled "Problem filling up my tank!" on 5/9/17.
Review this thread first because there are a variety of possible causes, solutions and videos that can possibly assist you.
In NBert's case it turned out to be a "...clogged carbon canister" which had to be replaced
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Hi there Geo,

Thanks a lot for the update! Will check it out and hope to get it done somehow. Thanks a lot man!

Cheers mate
 

·
Registered
Joined
·
10,546 Posts
@Geo K strikes again :) Glad you can dig up the references and posts ... really helps
@ Weps your issues list spans several threads (tstat, chirping, water pump, intake scoop hole ...) geewhiz
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
@jmc yea... I can tell that this car wont stay that much around me. At least if it was the amg tho... anyway. Thanks a lot guys. Appreciated!
 
1 - 5 of 5 Posts
Top