Mercedes CLA Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,735 Posts
Discussion Starter #1 (Edited)
Since the last 3 days, my driver heated seats work 1 of 2 times.

I start the car, i press the button, the 3 light doesn't light up. I shut the car off, open the door, close the door, start the car, and it work again... No issue with the passenger seats, only the driver seat. Every others buttons works.

It is winter here, maybe some snow got on to the connector under the seat, but i don't want to unplug it. I scare they gonna through AirBag error code on the dash...

Any suggestions ?
 

·
Registered
Joined
·
1,539 Posts
Since the last 3 days, my driver heated seats work 1 of 2 times.

I start the car, i press the button, the 3 light doesn't light up. I shut the car off, open the door, close the door, start the car, and it work again... No issue with the passenger seats, only the driver seat. Every others buttons works.

It is winter here, maybe some snow got on to the connector under the seat, but i don't want to unplug it. I scare they gonna through AirBag error code on the dash...

Any suggestions ?
Still under warranty? If yes, a simple dealer fix.
 

·
Registered
Joined
·
10,163 Posts
An obscure issue may be battery related especially in cold weather ... certain systems are “disabled” based on battery charge state. The door reset points to that cuz that “cheats” the system. Just a guess ... but yeah a dealer visit will yield a time chart for battery and charging system performance ... quite the jumpy charts
 

·
Registered
Joined
·
1 Posts
Since the last 3 days, my driver heated seats work 1 of 2 times.

I start the car, i press the button, the 3 light doesn't light up. I shut the car off, open the door, close the door, start the car, and it work again... No issue with the passenger seats, only the driver seat. Every others buttons works.

It is winter here, maybe some snow got on to the connector under the seat, but i don't want to unplug it. I scare they gonna through AirBag error code on the dash...

Any suggestions ?
Did you ever manage to figure out what the issue was? My 2015 has started doing there same thing where you press the heated seat button and sometimes it will shit off right away and sometimes it will stay on and run through the “ three,two,then one light “ properly
 

·
Registered
Joined
·
1,735 Posts
Discussion Starter #6
Not really, but i notice some moisture under the seat carpet during the winter. Maybe some water/snow got on the module under the seat.

I put a towel over it now and the problem never came back.
 

·
Registered
Joined
·
1,735 Posts
Discussion Starter #10
I have the WeatherTech, but i added duck tape all around because the lip did not go higher, much better now.
 

·
Registered
Joined
·
1,519 Posts
I wonder why most other Mercedes have covers on the modules and our model doesn't?
 
1 - 17 of 17 Posts
Top