Mercedes CLA Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2016 cla 250 and started having problems with my key fob not working as if the battery is dead. I would change the battery out of the key fob with a new one and it will work for a few minutes before appearing to go dead and stop working and if a change the battery out again with another new one it will work again but only for a few minutes before that battery stops working as well. Has anybody experienced a similar issue or know what the problem might be?
 

·
Registered
Joined
·
914 Posts
Welcome FPM :)
You should have 2 key fobs. Tell us about #2 - Is it working properly?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I bought the car used and it only came with one key fob unfortunately.
 

·
Registered
Joined
·
914 Posts
a) What month/year did you take possession of your 2016 CLA?
b) From a MB dealer?
Strongly recommend:
c) Retrieve the missing key from the seller....that's part of the CLA which belongs to you.
d) Also, we always recommend checking for codes -
d) The key you are using may have been corrupted at some point and may need replacement.
Other Members may have additional suggestions.
 

·
Registered
Joined
·
366 Posts
I have a 2016 cla 250 and started having problems with my key fob not working as if the battery is dead. I would change the battery out of the key fob with a new one and it will work for a few minutes before appearing to go dead and stop working and if a change the battery out again with another new one it will work again but only for a few minutes before that battery stops working as well. Has anybody experienced a similar issue or know what the problem might be?
I think it’s just a Keyless-Go thing. I’ve had to remove the Start button and insert the key a few times to start my GLS.
 

·
Registered
Joined
·
914 Posts
FPM doesn't say he has keyless start, but additional information from him such as a) & b) above will help with proposed solutions....how about it, FPM?
 

·
Registered
Joined
·
914 Posts
We will find out when FPM returns.
 

·
Registered
Joined
·
1 Posts
I have a 2016 cla 250 and started having problems with my key fob not working as if the battery is dead. I would change the battery out of the key fob with a new one and it will work for a few minutes before appearing to go dead and stop working and if a change the battery out again with another new one it will work again but only for a few minutes before that battery stops working as well. Has anybody experienced a similar issue or know what the problem might be?
This may sound crazy, but check the aux battery under passenger side dash. I’ve heard when that starts to go, it quits seeing fob and auto shutoff quits working too. It powers the ECM.
 

·
Registered
Joined
·
914 Posts
This may sound crazy, .....
Joe,
Not crazy at all!
In reply #4d above, we suggest looking for codes, as one of the normal first steps.
FPM's on board message system, if fully operational, also flashes a warning for that issue, but he is not indicating that warning, or any other clues for us :unsure:
 
1 - 11 of 11 Posts
Top