Mercedes CLA Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Upon starting my 2017 CLA 45 AMG all of a sudden 4 messages popped up simultaneously. The messages where Light Malfunction See Operators Manual, Check Front Left Turn Signal, Check Front Left Parking Lamp, and Check Left Low Beam. It seems to be all the front left functioning lights to be malfunctioning. The signal light on the right mirror and rear lights work fine. I checked the fuse #209 "LED headlamp: Left front lamp unit" and replaced it with the working right LED headlamp fuse. The lights were still out and upon removing the right LED headlamp fuse. It didn't shut off the right headlights and the signal was still working. Im assuming the fuses has nothing to do with the headlights or signal lights. Any idea what it might be. Would it be possible that all the bulbs went out at the same time?
 

·
Registered
Joined
·
1,742 Posts
Have you had any front end experiences or maintenance recently?
Can you check codes....AutoZone??i
 

·
Registered
Joined
·
1,742 Posts
Also, You are still under warranty....right?
 

·
Registered
Joined
·
12,134 Posts
Did a shutdown/restart resolve it?
HID or LED headlights?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Have you had any front end experiences or maintenance recently?
Can you check codes....AutoZone??i
Yes actually, the front right end of the vehicle was in a small collision the right headlights was damaged, it was replaced through insurance. This was 2 months back. Though it is not the correct side that stopped working, maybe it could be some kind of connection issue?
 

·
Registered
Joined
·
1,742 Posts
Yes actually, the front right end of the vehicle was in a small collision the right headlights was damaged,.... Though it is not the correct side that stopped working, maybe it could be some kind of connection issue?
a) Was the repair done at an MB Certified Repair Shop?
b) Can you check for codes?
 
1 - 8 of 8 Posts
Top