Mercedes CLA Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have had my CLA45 for 4 years now. Decided to install a downpipe and software update. It ran well for a month after the update then boom, Limp mode.

This happened a day after i replaced my spark plugs, it well into Limp mode (P0299) after hard acceleration but no CEL. No other codes except the P0299 (Low Boost). A week later my Cylinder Coil 2 died (replaced that) and still no change. Checked all the airpipes in the engine compartment and replaced all suspicious o-rings (no change). Took it to the dealer, they replaced the boost pressure regulator (no change). Also replaced the crankshaft sensor (no change). I have had P0897 for a while, before the limp mode issue.

Took it for further testing using Xentry, the fuel rail pressure is low on actuation test (P0087) but no CEL. I am not sure if this could b related. My car is out of warranty so the dealer will charge and arm and a leg to fully diagnose and fix.

I would appreciate some assistance.
 

·
Registered
Joined
·
189 Posts
you probably know what it is;
Error Code P0087 is defined as Fuel Rail/System Pressure Too Low. This indicates a fuel system problem, which is usually a fault within the fuel delivery system.
This error code is very similar to Error Code P0088. may be check fuil pump, its right no the top of the engine on the right side under the cover. its coverd by black foam kinda cover, fyi.

i got p0299 a few times, but when parked for a few min it when away and check engines gone away after, but it did happed a few more times but no check engie and other cases.
i got the dp and tune as well.
my car has 84k mile on it now 2015 so waist gate could be going bad. look into it.
i would fix the p0087 first might be related. driving the car with out turbo working is no big problem, but fuel sys i think is.
Good luck. sorry couldn't help though.
may be post here what you find out.
C
 
1 - 2 of 2 Posts
Top