Mercedes CLA Forum banner
21 - 27 of 27 Posts

·
Registered
Joined
·
12,603 Posts
think the c117 is 14-19 in the usa
then c118 20 on
c117 45s had the comfort / firm shock setting i believe which had a different tune than that in the 250s
something like that
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #24 ·
woww this is such a helpful post. i popped the hood and lo and behold, one of the cables was not connected to the top of the shock. seems the wiring from where the cable is supposed to connect to the shock somehow bent off. hopefully its an easy fix, and the solution to my issues. going back into the shop on monday and hope they can fix it. thank you so much for taking the time to respond.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #25 ·
it could also be your shocks are shot
yes i was thinking this too. i have almost 21k miles on the car, not sure if the shocks are covered by original warranty, which oddly i am still covered under. i know the shop will know how to test the shocks, but, respectfully i dont trust the shops much, is there a way that i, as an ignorant layman, can test the shocks besides riding over bumps? i wish i was more experienced in comparing the 'feel' of bad shocks vs good shocks. but im not. also i have new tires on, which is how i got the car, so i cant examine tires to see if shocks are bad. it does ride very straight though, without me having to fight to keep it straight. and i dont feel vibrations in steering wheel when i drive.
 
21 - 27 of 27 Posts
Top