Mercedes CLA Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
Hey everyone, Daniel here...

I come with another problem (unfortunately) and hope to find some answers around. Long story short... I was driving, chill, ac on and when I came to a stop the engine started mumbling like it was about to stall. I thought it was from our jerky transmission but it didnt seem to be it (thank God). Anyway, after driving it back home I realized that it does this 'stalling' only on low RPMs. Had the car diagnosed and got some errors, P0300 and P0303 (attached some goodies). Replaced the spark plugs, the ignition coil on cylinder 3 where the error initially was... but no luck afterall.

Now I see this "Turbocharger pressure sensor circuit; signal outside lower limit" and gives me bad days because I dont really get it. As far as I know and as I 'researched' the problem should be from a vacuum leak... maybe the gasoline or the DV.

If anyone knows anything or can throw an opinion on this, it would be very helpful because I'm out of luck and am trying my best to get it done asap... not because "car guy" but because holidays and... car guy :))

The car is a 2014 CLA 250, stage 1+, air filter, pops and bangs, custom exhaust...
PS: I got off the oil cap when the car was running (idle, ofc) and a lot of steam comes out of the engine... I got the DV off to 'clean' it and see if it's gripped or anything but no luck at all....
 

Attachments

·
Registered
Joined
·
1,655 Posts
Did the misfire go away when you replaced plug and coil?
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #3 ·
Did the misfire go away when you replaced plug and coil?
Yessir. The specific error for the cylinder 3 misfire got deleted and seems like it didn’t came back but still got those random/multiple misfire
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #4 ·
Just got back from a shop. Need to get down to the engine to see what's damaged. Compression from 14 to 2 on cyl. 3... new piston heads, timing chain... rebuild I guess :) fuck this car and this engine in particular :)
Ps: 140k km
 

·
Registered
Joined
·
12,298 Posts
Might be a leaky valve?
Then you can leave the bottom end alone
Hoping for the best
 
1 - 6 of 6 Posts
Top