Mercedes CLA Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi. Anyone here having engine rattling during cold startup?
Pls see attached video, rattling sounds at 4sec - 6 sec.

Also, my pre fl is losing the upshift sound(barrppp) even though the downshift sound is still as loud as when the car was new. The upshift sound is no more even though upshifting around 5k rpm.

 

·
Registered
Joined
·
9,873 Posts
That brief rattling is all the head mechanics slapping before oil sprays get to them
I get that at every cold start ... none during intra day trips with motor warm and lubed up
0w40 is a bit thin to cling over long periods
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
But it only started to sound like tat after the car has done abt 80k km, before tat mileage, it started without tat sound.

Anyway, I tot the 0w40 is the recommended weight, then what is the best weight to be used on our 45 engine?

Thanks for the reply.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Peeps, anyone can explain why there is no more barrpp when I upshift.


The sound I am talking abt is around 12s mark.

Thanks in advance for replying.
 

·
Registered
Joined
·
9,873 Posts
But it only started to sound like tat after the car has done abt 80k km, before tat mileage, it started without tat sound.
Anyway, I tot the 0w40 is the recommended weight, then what is the best weight to be used on our 45 engine?
Oh in that case not sure may want to check with service shop for advice
Maybe try 5w40 if your climate does not get too cold
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Oh in that case not sure may want to check with service shop for advice
Maybe try 5w40 if your climate does not get too cold
Cool. Will use 5w40 in my next oil change, abt 30km to go... wat the heck, will go get myself 5w40 and oil filter tomorrow and change the oil myself.

Thanks again.
 
1 - 6 of 6 Posts
Top