Mercedes CLA Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hey Guys,

Tried researching but no luck.
Just jumped into the car and the screen went blank, tried restarting the car and still no luck.

Is there a power on button or reboot somewhere?

Last resort would be taking it to the dealer but working 7 days doesn't help wahhhhh!!
 

·
Registered
Joined
·
12 Posts
I have had the same blank screen on occasion. I believe I have corrolated it to the Bluetooth on my phone being turned on before starting the car... but it is not consistent. As David170 wrote, pressing the center of the volume knob will turn on/off. If the screen goes blank, I press the button wait several seconds then press again and all seems to return to normal.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
I tried pressing it but it didn't turn on but held it down a few seconds and it did.

Thanks for the help guys.

Try unplugging the battery and let it restart to see if it works? I'm just guessing..
 

·
Registered
Joined
·
1,507 Posts
i would just take it back to the dealership and let them sort it out.
 

·
Registered
Joined
·
9,982 Posts
Not sure ... but if you get it ON again try holding the power button in until it restarts (reboot)???
Have to do this to set engineering mode changes...
 

·
Registered
Joined
·
1 Posts
Hey everyone,

I saw this thread and I thought I would share. The same thing happened recently with my 2016 CLA 250.

The COMAND Screen Display went out after I returned from shopping and started the car. No issues before. Anyway it stayed off and I tried using the "ON" button the radio to turn it on/off, but nothing.

However, the Sat radio, radio, bluetooth, navi, etc. still worked but I used the little screen in the dash to control them.

Anyway, I don't drive it a lot (about 3 times a week) but after being parked for 24hrs or so, I started the car and the COMAND Screen Display came back on. No issues - like nothing happened, nothing to see here... (twilight zone music).

Don't know if I hit a button or what not that turned it off. There is a "Display Off" on the COMAND Display screen, but the screen has to be on in the first place to see it...still don't know what happened.
 

·
Registered
Joined
·
3,888 Posts
This has happened to me 3 times.

The first time was after I had the car washed, so I assumed it was water. The dealership had no idea.

The second time, it was working when I got out of the car briefly, but not when I got back in. Ditto for the 3rd time.

I've tried the hold/reset thang to no avail, and reported it to create a paper trail in my warranty record. The service guy told me to take a picture of it next time (yeah, a picture of a black screen will illuminate the problem.)
 

·
Registered
Joined
·
142 Posts
Blanked entertainment screen is better than when my console screen went blank randomly in the first year of ownership. Had it looked at at the 1yr service and they supposedly updated the software. None since.
 

·
Registered
Joined
·
233 Posts
I just had this discussion yesterday with a work colleague, exact issue but on his brand new Toyota C-HR, screen randomly does not 'start' when vehicle starts, blank screen for up to a minute or so, then suddenly bursts into life down the road. I said it was obviously a Toyota specific issue, but now I find it is also an issue with our beloved Mercs...
 

·
Registered
Joined
·
9,982 Posts
I should think my word would suffice.
Yeah but it shuts them up pronto ... time is just too precious these days ... the 30sec spent explaining I could have done something else
Of course the video effort is 15sec so only 50% roi 😋
On this forum that 30sec would be about 5 0-60 runs 😜
 

·
Registered
Joined
·
5 Posts
Blank Screen

I have tried turning off my bluetooth on my phone and pressing the DVD eject button but neither works. Wondering which fuse if any should i try to change (Command) or (Command Display). Any Suggestions?
 

·
Registered
Joined
·
5 Posts
Blank Screen

Mykool,

If i disconnect and reconnect the battery will that help or should i also check the command display fuse?
 

·
Registered
Joined
·
1 Posts
Hey everyone,

I saw this thread and I thought I would share. The same thing happened recently with my 2016 CLA 250.

The COMAND Screen Display went out after I returned from shopping and started the car. No issues before. Anyway it stayed off and I tried using the "ON" button the radio to turn it on/off, but nothing.

However, the Sat radio, radio, bluetooth, navi, etc. still worked but I used the little screen in the dash to control them.

Anyway, I don't drive it a lot (about 3 times a week) but after being parked for 24hrs or so, I started the car and the COMAND Screen Display came back on. No issues - like nothing happened, nothing to see here... (twilight zone music).

Don't know if I hit a button or what not that turned it off. There is a "Display Off" on the COMAND Display screen, but the screen has to be on in the first place to see it...still don't know what happened.
Interesting, I had EXACT the same issue, which means it could be a common problem. it happen to me when I used the car a few times on and off for each trip maybe 20 or 30mins each trip, then on the very last time when the car turned on. the display unit just dead black. where as the small display on the dashboard still working as normal, then it will last for the rest the day, for the next morning, it back to normal.

did you find how to fix this problem?
 
1 - 18 of 18 Posts
Top