Mercedes CLA Forum banner

1 - 20 of 42 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start either, anybody have a similar experience?
 

·
Registered
Joined
·
1,122 Posts
"...Do Not Shift Gears, Visit Dealer". It won't start either...
…...
What model year do you have and which city are you near?

:mblogoblack:
 

·
Registered
Joined
·
1,294 Posts
Seems like a counterintuitive message to visit your dealer but not shift gears. How are you supposed to get there?
 

·
Registered
Joined
·
1,122 Posts
2014 cla250, in Bay area
..………...
CXU,
A) Looks like one of those situations, where a tow is required back to the dealer IMO - call your SA so that you can get a loaner.
B) No, I can't recall seeing this issue on the Forum - if there are no other clues like leaking fluid, then it is a possible software glitch.
C) Best of luck and please come back here and update us.
:mblogoblack:
 

·
Registered
Joined
·
2,973 Posts
I bought my 14 250 in Marin. I've primarily taken it to Fairfield Mercedes, as I used to work there, and now work in Vallejo. I've taken it for service to Marin once, when
Fairfield wouldn't investigate when I had a CEL that disappeared after a few days. Marin did and fixed the problem. Where are you located? I'm in Richmond, near El Cerrito.
 

·
Registered
Joined
·
6 Posts
This happened to me a few months ago and it was just the battery. They jumped my car to get it to the dealer (had to double jump it, whatever that means) and the dealer replaced the battery. Haven’t had the problem since. Hopefully that’s all your CLA needs too!
 

·
Registered
Joined
·
11,364 Posts
This happened to me a few months ago and it was just the battery. They jumped my car to get it to the dealer (had to double jump it, whatever that means) and the dealer replaced the battery. Haven’t had the problem since. Hopefully that’s all your CLA needs too!
that's good to know ...
no such notice when my batteries dropped dead after shutdown -> just the popping trunk syndrome ... :cool:
 

·
Registered
Joined
·
24 Posts
s
Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start either, anybody have a similar experience?
My '14 CLA250 4matic threw the same code when I was about 0.25 miles into my commute, but it was -14F out, simple turned the car off & on. Error cleared, has not shown-up again!
 

·
Registered
Joined
·
1,122 Posts
s

….simple turned the car off & on....
Great information, note that in cxu60's case "...it won't start either..."

Hope he gives us an update.

:mblogoblack:
 

·
Registered
Joined
·
5 Posts
same thing just happened to me last week. It wasn't starting for about almost 2 hours while waiting for the tow truck then I tried one more time it started. Taking it to the dealer in two days. Anybody know what this issue can be?
 

·
Registered
Joined
·
2 Posts
same thing just happened to me last week. It wasn't starting for about almost 2 hours while waiting for the tow truck then I tried one more time it started. Taking it to the dealer in two days. Anybody know what this issue can be?
same thing just happened to me last week. It wasn't starting for about almost 2 hours while waiting for the tow truck then I tried one more time it started. Taking it to the dealer in two days. Anybody know what this issue can be?
Did u have any chek engine light on the dash because that happens to me last night but when the car turned on the check engine light come out and is still there let me know please
 

·
Registered
Joined
·
5 Posts
I took it to a local car shop , the engine light was on they ran their diagnostics they said they couldn’t help me that I’d have to bring it to the dealership it’s most likely a computer software issue which I’m scheduled to do on Thursday . I will update you . The engine light is no longer on by the way
 

·
Registered
Joined
·
11,364 Posts
if the CEL stayed on for any length of time, hopefully there will be a stored or persistent error code stored and they can track it down ... fingers crossed for you folks !!
 

·
Registered
Joined
·
1 Posts
same thing just happened to me last week. It wasn't starting for about almost 2 hours while waiting for the tow truck then I tried one more time it started. Taking it to the dealer in two days. Anybody know what this issue can be?
Hey man so has the car ever been stuck in park? First off really quick a brake light switch can cause a car to not start and or be stuck in park, but let me tell youvmy story. Recently my car got stuck in park i kept trying to shift out of park and then the Service Required do not shift gears came up on my screen. I let the car sit for a day, it turned on fine and drove the next day. No codes no service required messages came up after letting it sit for a day. 3 months later, yesterday, I woke up got in my car turned it on and tried to put it in drive, no response. I called a friend of mine a mercedes tech and he told me Brake Light Switch, they tend to go bad in mercedes. The brake like switch is a small mechanism that clicks, the clicker could be stuck. The brake light switch is located under the steering wheel compartment to the left under the light switches. It has two wires connected to the back of it and in the front of it which may be hard to see, there will be a little thing sticking out that can click youll know exactly what im talking about if you see a picture of the brake light switch. Youll have to click the switch and then try to put it in drive. “A faulty brake light switch can causemany problems. If a switch is bad, the brake lights won't operate and the transmission shifter will not come out of "Park" position. In cars with a push-button start system, a faulty brake light switch can cause the vehicle not to start.”

This is for anyone with a similar problem, hopefully this could help someone in the future since the information was no where to be found online when i needed it.
 

·
Registered
Joined
·
11,364 Posts
Good info ... makes sense since even proper operation goes through the brake pedal and/or brake light switch circuit(s)
Presume a simple test would be to disconnect the switch at the brake pedal and see what happens
Though for nonpushbuttonstart (like mine) the brake pedal is not needed for ignition
 

·
Registered
Joined
·
1 Posts
Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start either, anybody have a similar experience?
Just got this warning on my 2015 CLA45. Had it towed to the dealer. They are still diagnosing. Anyone else have luck diagnosing a common problem here?
 

·
Registered
Joined
·
2 Posts
Just got this warning on my 2015 CLA45. Had it towed to the dealer. They are still diagnosing. Anyone else have luck diagnosing a common problem here?
I have seen this error twice, both times when the car sat outside in the cold over the night, when inspecting the codes with a computer I saw a more accurate error that says something along the lines of "transmission computer temperature warning."another commenter on here said it happened after a cold night.

If the computer sensitive to cold as well as heat for a reason ?
 
1 - 20 of 42 Posts
Top