Mercedes CLA Forum banner

41 - 54 of 54 Posts

·
Registered
Joined
·
1 Posts
This just happened to me today while at work it has been raining here in Houston the last couple of days. I have a 2015 Mercedes Benz CLA250 when i got in my car to go get some lunch i turned the car on and it did not start but everything else did (radio,ac, etc.) i turned it off and tried again this time the car did not start but the message popped up saying to not shift gears and to take to a dealership. I tried it one more time and the car started the message came off but my engine light is still on. I took the risk to drive it down the street and it worked fine. I parked it turned off and on and it was fine (engine light still on). I just wanted to see if anybody had advice as to what i should do.
 

·
Registered
Joined
·
1,243 Posts
Welcome Serg to the CLA Forum:)
Could be caused by a number of issues, including battery.
Suggest your best next step is to check for codes. If you don't feel it is convenient to visit the dealer, AutoZone will do it at no cost, but phone them first, due to the virus.
The codes your CLA shows will pinpoint the specific areas, which need attention and this is what the dealer will likely do as the first step in creating a diagnosis.
Other Members will likely have additional comments.
 

·
Registered
Joined
·
1 Posts
Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start either, anybody have a similar experience?
Could you please tell what was it ? I have same message showing . Thank You .
 

·
Registered
Joined
·
1 Posts
I had this same issue twice (August 2020 and September 2020). Took it to Christian Brothers (certified auto) the first time and they replaced the TCM (Transmission Control Module), the second time they found the battery was completely dead and would not hold a charge. After reading up on this issue, I would suggest checking the following......

1.) battery (amp draw and voltage) even though the lights and everything gets power there is not enough volts to power up the vehicle. If it is the battery then replace and problem should go away. (FYI the battery is not cheap - $199)
2.) check the diagnostic codes and if you get a TCM code then replace the TCM (only replace if battery replacement does not work)
3.) Brake Light Switch (last resort and is very easy to replace, part alone costs up $22)
 

·
Registered
Joined
·
1,243 Posts
Welcome to the CLA Forum @yo9adiktion:)
And thank you for your valuable insight!
 

·
Registered
Joined
·
1 Posts
Last night, when I was trying to drive out, and saw the error code "Service Required: Do Not Shift Gears, Visit Dealer". It won't start either, anybody have a similar experience?
It just happened to me today!
 

·
Registered
Joined
·
1,243 Posts
Welcome Kiki to the CLA Forum :)
You are indeed reviewing the correct thread. What are the car details?
 

·
Registered
Joined
·
49 Posts
Any feedback on how long the battery lasts in CLA’s. We got about 3 years out of the 2016 car before it went from perfect to zero overnight.
I just changed out my 2 batteries. They were in the car for 6 years. The main battery was down to 31% to 248 CCA. My stop-start is working again
 

·
Registered
Joined
·
1 Posts
you have to change your battery. That is it.

This just happened to me today while at work it has been raining here in Houston the last couple of days. I have a 2015 Mercedes Benz CLA250 when i got in my car to go get some lunch i turned the car on and it did not start but everything else did (radio,ac, etc.) i turned it off and tried again this time the car did not start but the message popped up saying to not shift gears and to take to a dealership. I tried it one more time and the car started the message came off but my engine light is still on. I took the risk to drive it down the street and it worked fine. I parked it turned off and on and it was fine (engine light still on). I just wanted to see if anybody had advice as to what i should do.
 

·
Registered
Joined
·
1,243 Posts
Welcome to the CLA Forum Josephab :)
Looks like you are reviewing the correct thread.
 

·
Registered
Joined
·
1 Posts
2015 Cla 250 here 👋
Just had this happen today. Message popped up warning not to switch gears and to visit the dealership, wouldn’t start the first go but did the second. Drove it, stopped it. Wouldn’t start at all, took about 9 try’s before it would start again and this time the check engine light remained on as I proceeded to drive it to a local car part place, got the battery tested (31%) changed it myself on the spot. After that it turned on perfect, check engine light was off and even the eco start stop started working after not working for 7 months ish. hope this information helps for anyone else, the gears shifted just fine but dead battery seemed to be the culprit? Also would anyone else know why the battery light didn’t come on or any other battery related warnings since the issue was seemingly the battery? Going back tomorrow to check the alternator and maybe do an OEM read just incase. But it drove fine after battery replacement. Here’s to hoping that’s all it was.
 

·
Registered
Joined
·
1,243 Posts
2015 Cla 250 here 👋
... Also would anyone else know why the battery light didn’t come on or any other battery related warnings since the issue was seemingly the battery? Going back tomorrow to check the alternator and maybe do an OEM read just incase. But it drove fine after battery replacement. Here’s to hoping that’s all it was.
Welcome to the CLA Forum @Dip_1212 :)
Excellent information...Thank you.
 
41 - 54 of 54 Posts
Top