Mercedes CLA Forum banner
41 - 60 of 64 Posts

·
Premium Member
Joined
·
13,127 Posts
over several decades for me various starters have gone at all stages young and old luck of the draw
though to maximize the service life of my current starter i kill the eco … so lower probability of repairs (just a numbers game)
the eco mode saves fuel under certain conditions like bloody long red lights
though the transient energy burn requirements supersede the savings for short stops and associated time/rate of use
even the system itself kills the eco mode after successive short haul activations (think its 4?)
there was this drawn out paper with a whole bunch of differential equations to see how an eco system could save fuel … came out with the usual handwaving results and the “it depends” gibberish … that was a real “duh”
 

·
Registered
Joined
·
2,226 Posts
My ground wires are burnt....
I'm gonna have to redo the harness.
Felipe, I see you have stated a new subject "No Revs, car won't move"
a) Is it still in the shop?
b) Was it the shop that replaced the harness?
c) What was the cause of the ground wires burning?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #43 ·
Felipe, I see you have stated a new subject "No Revs, car won't move"
a) Is it still in the shop?
b) Was it the shop that replaced the harness?
c) What was the cause of the ground wires burning?
Yes I did. Different problem. Car starts now. But it wont drive. New starter from Mercedes benz under warranty thru gvc.

I had the car towed home.

The harness issue was on a different vehicle. Disregard.
 

·
Registered
Joined
·
2,226 Posts
With this new issue, have you checked for codes?
 

·
Registered
Joined
·
2,226 Posts
Yes I did. Different problem. Car starts now. But it wont drive. New starter from Mercedes benz under warranty thru gvc....
Hard to believe no codes. If the shop was an MB dealer, or one with access to the proprietary STAR* System, step by step procedures should have been followed,
a) Have you been able to look for loose or missing connections?
b) Retracing the starter replacement steps may show you what was done incorrectly.
c) Since it is most likely a shop screw-up, you have a valid case to discuss with the shop owner.
d) Have a different MB dealer troubleshoot, repair and then give bill the original shop.
 

·
Registered
Joined
·
2,226 Posts
Yes I did. Different problem. Car starts now. But it wont drive. New starter from Mercedes benz under warranty thru gvc...
Do you mean GWC?
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #48 ·
Hard to believe no codes. If the shop was an MB dealer, or one with access to the proprietary STAR* System, step by step procedures should have been followed,
a) Have you been able to look for loose or missing connections?
b) Retracing the starter replacement steps may show you what was done incorrectly.
c) Since it is most likely a shop screw-up, you have a valid case to discuss with the shop owner.
d) Have a different MB dealer troubleshoot, repair and then give bill the original shop.

I have not checked beyond what's visible with the battery installed. I know they have had to remove the battery tray to install the new starter. I don't know what's underneath, I don't expect much in terms of loose connections.

The scanner I have is a cheap ebay scanner. I doubt it would pull up my codes but it does read 3 systems whereas in jeep it only reads 2.

The closest mb dealer is a 3 hour drive away. It's inaccessible.

As for the warranty, provided there's no foul play it should be covered. 4000 per incident with a 75 deductible.

Gwc ow gvc. Not sure.
 

·
Registered
Joined
·
160 Posts
I have not checked beyond what's visible with the battery installed. I know they have had to remove the battery tray to install the new starter. I don't know what's underneath, I don't expect much in terms of loose connections.

The scanner I have is a cheap ebay scanner. I doubt it would pull up my codes but it does read 3 systems whereas in jeep it only reads 2.

The closest mb dealer is a 3 hour drive away. It's inaccessible.

As for the warranty, provided there's no foul play it should be covered. 4000 per incident with a 75 deductible.

Gwc ow gvc. Not sure.
You need proper Mercedes STAR or equivalent.

Generic ebay code readers do not work with Mercedes.

I have similar. It will work on a vast array of car makes however does not work on Mercedes
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #50 ·
You need proper Mercedes STAR or equivalent.

Generic ebay code readers do not work with Mercedes.

I have similar. It will work on a vast array of car makes however does not work on Mercedes
I'm taking the car to a European shop on the 20th. I already have towing lined up. And with $4000 in coverage per incident I should be fine. After all, short of foul play, the car was drivable and I'd never had a problem since 45k when I bought it. It now has 78k. All highway miles. Not even joking. My commute is 10 hours from where I live to Toronto one way.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #51 ·
I tried to reset service b but I failed. I used to hold the phone button plus the ok button to access the menu. Then I went to assist plus and selected conf. Full service. From there i tried to reset one of the oil changes and it succeeded but the others failed. Then I started the car and a bunch of codes got thrown and the engine started but it almost stalled. Here are the codes the scanner reads:

P050A
P2610
P050A
P050A

And their descriptions are:

cold start idle air control system performance
ecm/pcm internal engine off tkmer performance
cold start idle air control system performance
cold start idle air control system performance

There are 4 codes
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #54 ·
just a thought … check the vacuum lines
I checked everything I could. I removed the battery tray to see under. Checked for anything obvious.

I have an appointment on the 20th at a European shop and a tow lined up too. Beyond cleaning there isn't much I can do.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #56 ·
Font Material property Publication Paper Writing



Found the problem. First shop stuffed a rag into the intake while servicing starter. Rag made it to turbo housing. 2nd mechanic reset throttle. Cleared codes. Reset service schedules.
 

·
Registered
Joined
·
2,226 Posts
41 - 60 of 64 Posts
Top